localendar Forums Homepage

Print at Jun 23, 2018, 3:25:15 PM View all posts in this thread on one page
Posted by OPwebmaster at Jan 28, 2015, 12:52:27 AM
Custom Category Legend problems
I have created 6 custom category legends, and I have checked on Event Editor ->Custom Category both 'include a category legend on your public calendar' and 'hide default localendar categories on the Event Editor'. The legend appears correctly on Month, Day & Week views.

However, checking/unchecking the categories only changes the displayed events on the Month page. ALL events are shown on the Week and Day page, no matter what categories are checked/unchecked on the Week and Day pages.

Also, on the Week page, there is a small square box preceeding the text for each event, which matches the color code set for that Event. But the Day page does not show any such colored boxes.

The sample link referenced in your documentation:
http://www.localendar.com/public/sample_category
has the exact same problems that I am experiencing.

This difference in how this operates depending on the selected view is very confusing to the user.

Is there a setting somewhere that I may have missed, or is this the way the program is designed to work? If it is, then I would like you to see if it can be corrected in a future update.

Thanks,


Harry

Posted by support at Feb 9, 2015, 1:16:37 AM
Re: Custom Category Legend problems
Are you sure it's not working? Perhaps you should check again... wink
----------------------------------------
Marc Higgins
Support Associate, localendar.com
Follow us on Twitter! http://www.twitter.com/localendar_news

Posted by OPwebmaster at Feb 9, 2015, 5:43:52 AM
Re: Custom Category Legend problems
Marc:

Thanks so much for fixing these.


Harry

Posted by OPwebmaster at Feb 16, 2015, 1:14:37 AM
Re: Custom Category Legend problems
Marc:

A variation to this problem has now appeared.

In the Month view, unchecking 'Show All' removes the events, but thin horizontal lines of the appropriate colors show. This is how it should be.

But in Week or Day view, there is no thin horizontal line. I swear they were there before, but I don't have any screen shots with 'Show All' unchecked.

The sample link referenced in your documentation:
http://www.localendar.com/public/sample_category
has the exact same problems that I am experiencing.

Let me know if my memory is faulty, or this is a new problem.


Harry

Posted by support at Feb 18, 2015, 8:27:11 PM
Re: Custom Category Legend problems
I think you pointed out that we weren't showing the category color blocks on the day or week views. Yes; we prefer there to be a thin colored line just so viewers know there are events there that haven't been selected. On the month view, where the background color of the event is the custom color, this is actually a "free" feature we get b/c of how the browser renders the events.

On the D/W views, the background color is not the event category color. So when they are hidden, they are completely invisible. The lines were never there before (sorry memory!), and I don't see any open issues related to adding them at this time.
----------------------------------------
Marc Higgins
Support Associate, localendar.com
Follow us on Twitter! http://www.twitter.com/localendar_news

Posted by OPwebmaster at Feb 19, 2015, 4:06:18 AM
Re: Custom Category Legend problems
 
On the D/W views, the background color is not the event category color. So when they are hidden, they are completely invisible. The lines were never there before (sorry memory!), and I don't see any open issues related to adding them at this time.


Marc:

At my age, my memory often is sorry. sad

Thanks for the clarification on how it all works. Consider this topic closed.


Harry


Help! | Cobranding | Legal | Privacy Policy | About localendar.com | Contact Us