localendar Forums Homepage

Print at Nov 20, 2018, 10:02:28 PM View all posts in this thread on one page
Posted by MorrisMediator at Aug 1, 2017, 7:42:10 PM
VERY Slow Loading of the Calendar I-Frame
We are experiencing very slow loading of the calendar i-frame on our website. We have contacted Technical Support and have not received a reply. Why don't you have a phone number that subscribers can reach you at? This issue is critical to resolving for our business and our clients depend on accessing the calendar to make appointments. Please advise immediately.

Posted by summitacademy at Aug 9, 2017, 2:54:03 PM
Re: VERY Slow Loading of the Calendar I-Frame
Same here! We've been experiencing very slow loads for the past 4-5 days at least.

Posted by jasonsullivan at Aug 15, 2017, 1:16:33 AM
Re: VERY Slow Loading of the Calendar I-Frame
We're looking into the performance issues.
----------------------------------------
Jason Sullivan
Support Associate
Localendar.com

Posted by support at Aug 16, 2017, 8:27:14 PM
Re: VERY Slow Loading of the Calendar I-Frame
I ran a Google pagespeed (https://developers.google.com/speed/pagespeed/insights/) test against both of your calendars..

For SummitAcademy, the response time was 1.8 seconds on mobile, and .86 seconds on desktop browsers

For MorrisMediator, it was 1.4 and 1.7, respectively.

Keep in mind that the perceived load speed can be affected by any of the (potentially many) servers between your computer and localendar's servers.

If you experience any performance issues, noting the time of day would be helpful, as would be using a tool like https://www.uptrends.com/tools/website-speed-test

(saving a screen shot of the results would also be useful for further investigation).

I'll save a discussion about "tracert" and how it can show the real path your data is taking across the internet for a future post.
----------------------------------------
Marc Higgins
Support Associate, localendar.com
Follow us on Twitter! http://www.twitter.com/localendar_news

Posted by OPwebmaster at Aug 22, 2017, 12:37:03 AM
Re: VERY Slow Loading of the Calendar I-Frame
Marc:
 
I ran a Google pagespeed
(https://developers.google.com/speed/pagespeed/insights/) test against
both of your calendars..
I never knew these tools existed. Thanks for sharing them.

I could not get Google pagespeed to reliably indicate times. It only
wanted to give me info on whether the site is 'Good', 'needs work',
etc.
 
If you experience any performance issues, noting the time of day would
be helpful, as would be using a tool like
https://www.uptrends.com/tools/website-speed-test
I used uptrends.com for timing, and New York as the test point. Here
is what I found for three sites:
1. This is the page on my website where Localendar is installed in a
rectangle: http://www.ottawapark.org/calendar-ottawa-park-toledo.html
Total time: 2.7 seconds
Waiting for localendar: 1.75 seconds

2. This is a direct link to my localendar on your site:
http://localendar.com/public/OPwebmaster?rss_link=false
Total time: 1.9 seconds
Receiving localendar: 1.5 seconds

3. This is the way I access forums on your site (does not include
logging in step):
http://www.localendar.com/lcf/lcforums/listforums?c=9
Total time: 18 seconds
Waiting for localendar: 17.9 seconds

Based on these brief tests, it seems that localendar is the problem
with slow loading.
 
(saving a screen shot of the results would also be useful for
further investigation).
I have all my screen shots saved. But is there a way to upload them
directly to this forum? In the past I have uploaded documents to my
server, and then provided a link to them with my forum messages. But
that is much more time consuming than just uploading directly.

FYI: If someone tries to 'Reply with Quote' to your post, he gets a message saying that the reply contains spam, and cannot be accepted. I was able to do it by setting us a new message, and then cutting and pasting your quotes into it. Also, the link to contact when one gets the spam message leads to your old support Email, not what shows in 'Contact Us'.

Harry

Posted by support at Aug 30, 2017, 1:27:59 AM
Re: VERY Slow Loading of the Calendar I-Frame
Yeah, I think the spam filters on the forums did not like the google links I included for some odd reason. We use a 3rd party API for that.

Anyway, we have added additional memory and cpus to our new cloud servers. When I run Google pagespeed for your calendar I now get a response time of .44 seconds.

The forums are still slow at ~7 seconds, but not really a subject of optimization for us with all the other stuff we have to work on.
----------------------------------------
Marc Higgins
Support Associate, localendar.com
Follow us on Twitter! http://www.twitter.com/localendar_news

Posted by OPwebmaster at Aug 31, 2017, 3:52:23 AM
Re: VERY Slow Loading of the Calendar I-Frame
Marc:
 
Anyway, we have added additional memory and cpus to our new cloud servers. When I run Google pagespeed for your calendar I now get a response time of .44 seconds.

The forums are still slow at ~7 seconds, but not really a subject of optimization for us with all the other stuff we have to work on.

Thanks for adding the memory/cpus. Although I still can't get Google pagespeed to provide a response time, my repeat tests using website-speed-tests shows time cut by at least 50% on everything I tested, including the forums. Great work.

Harry


Help! | Cobranding | Legal | Privacy Policy | About localendar.com | Contact Us