Welcome Guest   | Login   
  Search  
  Index |  Recent Threads |  Register | 


Quick Go »
Thread Status: Normal
Total posts in this thread: 7
[Change thread status] [Delete this Thread] [Move this Thread]
[Add To My Favorites] [Watch this Thread] [Post new Thread]
Author
Previous Thread This topic has been viewed 69 times and has 6 replies Next Thread
Grange
New Member



Joined: Oct 29, 2014
Posts: 14
Status: Offline

Edit this Post   Category filters not quite working Reply to this Post
Reply with Quote
[Delete this Thread]

Hi, I have set up a site at leighsnelson.co.uk/GrangeCalendar

There are a couple of pages with different embedded calendars showing different events. There is an issue with the filters at the bottom of the calendars not updating correctly.

For example, if you click on "Sixth Form" the the correct calendar loads, but the filters on the bottom remain the same as the previous calendar that you were on. If you then move onto another month then you get the correct filters at the bottom.

Is this a known problem or is it something you would be able to help me with?

Thanks in advance.

Leigh
[Jan 13, 2016, 11:55:10 AM] [195.62.222.210] Show Post Printable Version [Link] Report threatening post: please login first  Go to top 
Grange
New Member



Joined: Oct 29, 2014
Posts: 14
Status: Offline

Edit this Post   Re: Category filters not quite working Reply to this Post
Reply with Quote
[Delete this Post]

I have set categories on all of the pages and it seems fine, but as another problem, when I log into localendar at the same time as looking at a filtered calendar in another tab the entire back end of localendar only displays the filtered categories too.

Maybe it is a caching error?
[Jan 13, 2016, 3:26:48 PM] [195.62.222.210] Show Post Printable Version [Link] Report threatening post: please login first  Go to top 
Grange
New Member



Joined: Oct 29, 2014
Posts: 14
Status: Offline

Edit this Post   Re: Category filters not quite working Reply to this Post
Reply with Quote
[Delete this Post]

It is certainly a Caching issue. If I jump between two pages with filtered calendars I only see the first pages filter on both calendars but if I "Shift + F5" on the second calendar then it clears the Cache and I see the new filter.

I can get around this by re-loading the page but it is not a very good experience at the moment.
[Jan 14, 2016, 9:09:49 AM] [195.62.222.210] Show Post Printable Version [Link] Report threatening post: please login first  Go to top 
OPwebmaster
localendar Expert



Joined: Jan 24, 2015
Posts: 282
Status: Offline

Edit this Post   Re: Category filters not quite working Reply to this Post
Reply with Quote
[Delete this Post]

I see the problem, but I wonder if caching is the root problem. I found moving from one calendar page to another was very very slow, and sometimes I had to do a Refresh (Ctrl+F5 on Firefox) to even get the next page to appear. Localendar moves between months quickly, so it does not seem to be internal to Localendar.

I don't know how you have coded this to move between calendar pages, but it seems like it is going into some kind of loop, which Refresh stops.

I'm no coding expert, so this is just a guess.


Harry
[Jan 15, 2016, 5:53:51 AM] [72.241.195.138] Show Post Printable Version [Link] Report threatening post: please login first  Go to top 
Grange
New Member



Joined: Oct 29, 2014
Posts: 14
Status: Offline

Edit this Post   Re: Category filters not quite working Reply to this Post
Reply with Quote
[Delete this Post]

Hi

As far as I am aware I have just used a HTML template and copied the embedded iframe into the correct place. Seems a very odd situation.

Leigh
[Jan 15, 2016, 8:56:43 AM] [195.62.222.210] Show Post Printable Version [Link] Report threatening post: please login first  Go to top 
OPwebmaster
localendar Expert



Joined: Jan 24, 2015
Posts: 282
Status: Offline

Edit this Post   Re: Category filters not quite working Reply to this Post
Reply with Quote
[Delete this Post]

Leigh:

>>Seems a very odd situation.<<

I agree. I opened two tabs on my browser, and placed one of your pages in each. Just switching between the two tabs took a very long time.

Could there be an issue with the HTML template that you used?

Localendar support will have to help you at this point. You have exceeded by skill level.


Harry
[Jan 16, 2016, 6:45:45 PM] [72.241.195.138] Show Post Printable Version [Link] Report threatening post: please login first  Go to top 
support
localendar Expert
Member's Avatar


Joined: Sep 15, 2004
Posts: 6027
Status: Offline
Edit this Post   Re: Category filters not quite working Reply to this Post
Reply with Quote
[Delete this Post]

Thanks Harry,

Actually, this is a known issue. The filters run into trouble if you are using multiple views of the same calendar. Presently, they are attached to the calendar itself, and not a specific view of the calendar.

So, change a filter on one calendar view, and it gets changed for all of them.

While the issue is easy to describe, it's not so easy to fix, which is why we haven't done so already. The re-loading of the page (clearing the cache) resets you back to the default filter, but the problem will just re-occur as soon as a new filter is set.
----------------------------------------
Marc Higgins
Support Associate, localendar.com
Follow us on Twitter! http://www.twitter.com/localendar_news
[Jan 25, 2016, 11:49:25 PM] [24.190.224.252] Show Post Printable Version [Link] Report threatening post: please login first  Go to top 
[Show Thread Printable Version] [Post new Thread]

Help! | Cobranding | Legal | Privacy Policy | About localendar.com | Contact Us